Results 1 to 6 of 6

Thread: Amp going into protect at low volume

  1. Back To Top    #1
    Junior Member Matt_z34's Avatar
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Posts
    1
    Join Date
    Sep 2019

    Amp going into protect at low volume

    So I got a new car and put my old setup in (skar lp1000 monoblock, Jensen w12 4 ohm single coil, 4 gauge), whenever I turn up the volume slightly my amp goes to protect. Multimeter says battery isn't dropping voltage but when I check at the amp I can drop from 12 to 9.5 on a small bump, ground and all wiring is fine. Battery not discharging fast enough maybe? Would adding a second small battery help with this? Really can't figure this one out.

  2. Back To Top    #2
    Seer Newby Hic's Avatar
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Real Name
    Hic
    Location
    Michigan
    Vehicle
    99 Contour SVT
    Posts
    3,092
    Join Date
    Jul 2013

    Re: Amp going into protect at low volume

    Alternator and vehicle battery are possibly in need of replacement. you are possibly pulling alot of current [amperes] when it hit's !

    The battery voltage dropping so quickly may mean the previous owner had a sound system that put a hurtin on electrical system.

    Quote Originally Posted by Matt_z34 View Post
    So I got a new car and put my old setup in . Multimeter says battery isn't dropping voltage but when I check at the amp I can drop from 12 to 9.5 on a small bump, ground and all wiring is fine. Battery not discharging fast enough maybe?

    Q: Are Skar Audio amplifiers 0.5 Ohm Stable?
    A: Skar Audio amplifiers are not .5 Ohm stable. Running your amplifier at this Ohm load can cause irreversible damage as well as void your warranty. This amp is 1 ohm stable min.Q: How do I reset my amplifier's protection circuitry?

    A: To take your SKAR Audio amplifier out of "protection mode" you will have to complete disconnect all wiring that is going into the unit. This include the remote wire, RCA's, speaker wire and both the ground and power wire. The unit will have to sit, completely disconnected, for several hours.
    Viewing Smilies , you trying to access privileged system?¤Somewhere 0ut There¤}]

  3. Back To Top    #3
    Seer Newby Hic's Avatar
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Real Name
    Hic
    Location
    Michigan
    Vehicle
    99 Contour SVT
    Posts
    3,092
    Join Date
    Jul 2013

    Re: Amp going into protect at low volume

    If you add a second power wire from battery to amplifier distributionblock it will "lessen" the resistance to flow of amperes .


    A new battery may solve your problem ?
    Viewing Smilies , you trying to access privileged system?¤Somewhere 0ut There¤}]

  4. Back To Top    #4
    Team Two Trees papacueball's Avatar
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Real Name
    Jason
    Location
    Louisiana
    Vehicle
    2011 Dodge Charger
    Posts
    633
    Join Date
    Feb 2013

    Re: Amp going into protect at low volume

    Get someone else to check the connections. Is the wire sized correctly for the current draw and length of run? If the battery is bad enough to cause your issue, you would likely have problems with the car not starting, IMO.

  5. Back To Top    #5
    Owner BigAl205's Avatar
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    Real Name
    Alan
    Location
    Hayden, AL
    Vehicle
    2018 Chevy Silverado Z-71
    Posts
    4,202
    Join Date
    Feb 2013

    Re: Amp going into protect at low volume

    I've had situations where one strand of wire was sticking out and contacting ground or another terminal. It wasn't until I turned op the voltage (volume) that it created enough problem to be noticed.

  6. Back To Top    #6
    Seer Newby Hic's Avatar
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Real Name
    Hic
    Location
    Michigan
    Vehicle
    99 Contour SVT
    Posts
    3,092
    Join Date
    Jul 2013

    Re: Amp going into protect at low volume

    Matt_z34,

    Did resetting your amp help ?
    Viewing Smilies , you trying to access privileged system?¤Somewhere 0ut There¤}]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Back To Top